Resolver problema do YARPP no WordPress?

Fiz uma atualização no meu blog outro dia e um plugin começou a dar erro. Isso mesmo o YARPP – Yet Another Related Posts, que é um plugin que gera os artigos relacionados com o que usuário do site está lendo agora. O problema era bem chato, pois ficava aquela bendita mensagem:

Warning: ksort() expects parameter 1 to be array, object given in wp-content/plugins/yet-another-related-posts-plugin/classes/YARPP_Cache.php on line 465
Wordpress YARPP

WordPress YARPP

Dai você vai me perguntar e como eu resolvi? Simplesmente direi que no meu caso foi simples, mas no seu vai depender muito pois o Yarpp faz um cache dos posts relacionados e isso pode gerar alguns problemas as vezes, então o que precisa pra resolver é saber se você está usando algum gerenciador de cache junto ao seu wordpress, tipo WPCache ou WPSuperCache e limpar o cache deles, caso esteja usando algo diretamente no servidor como o Varnish, vai precisa esperar ou se tiver como limpar o cache nele.

Essa solução é bem simples, mas lembre-se sempre de deixar seu WordPress sempre atualização, não só ele como todos os plugins que podem resolver falhas de segurança e outras como essa.

, , , ,